The Moroccan Geek

Des bits d'information qui enrichissent votre quotidien!

Modem Huawei E156 g Méditel sous BackTrack / Ubuntu

L’un des points forts des dernières distributions linux, surtout celles basées sous debian, est leur capacité d’intégration des librairies des nouveaux périphériques et leur prise en charge complète de ces derniers (Même si des fois, il faut galérer pour les faire marcher ; p)

La preuve c’est qu’on va essayer de  faire marcher le modem Huawei E156 G de méditel, et de se connecter avec, sans effort et sans avoir à télécharger ni à compiler quoi que ce soit et ceci en utilisant wvdial!

A vos Claviers!!!

1-Assurez vous d’être connecté en Root dans le terminal (Sinon utilisez sudo -s)

2-tapez : wvdialconf , pour que votre modem soit détecté et configuré automatiquement. Vous devez avoir quelques choses du genre dans votre terminal :

root@home:~# wvdialconf
Editing `/etc/wvdial.conf’.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 — OK
ttyUSB0<*1>: ATQ0 V1 E1 Z — OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 — OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 — OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 — OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
ttyUSB0<*1>: Modem Identifier: ATI — Manufacturer: huawei
ttyUSB0<*1>: Speed 9600: AT — OK
ttyUSB0<*1>: Max speed is 9600; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 — OK
ttyUSB1<*1>: ATQ0 V1 E1 Z — OK
ttyUSB1<*1>: ATQ0 V1 E1 S0=0 — OK
ttyUSB1<*1>: ATQ0 V1 E1 S0=0 &C1 — OK
ttyUSB1<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 — OK
ttyUSB1<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
ttyUSB1<*1>: Modem Identifier: ATI — Manufacturer: huawei
ttyUSB1<*1>: Speed 9600: AT — OK
ttyUSB1<*1>: Max speed is 9600; that should be safe.
ttyUSB1<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK

Found a modem on /dev/ttyUSB0.
Modem configuration written to /etc/wvdial.conf.
ttyUSB0<Info>: Speed 9600; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0”
ttyUSB1<Info>: Speed 9600; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0″
root@home:~#

3-Votre modem étant détecté, on va modifier son fichier de configuration pour y ajouter les informations nécessaires à la connexion, pour cela on tape :

kate /etc/wvdial.conf  (si vous avez une fenêtre qui apparait, choisissez ouvrir une nouvelle session!)

Vous pouvez remplacer kate par votre éditeur préféré (vi par exemple!).

Arrivé à cette étape, vous verrez ceci:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
; Phone = <Target Phone Number>
; Password = <Your Password>
; Username = <Your Login Name>

Enlevez les points virgules devant Phone, Password & Username et ajoutez ” Stupid Mode = 1″ puis faites en sortes qu’il ressemble à ceci :

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = *99#
Password = MEDINET
Username = MEDINET

Stupid Mode = 1

5-Enregistrez votre configuration puis Connectez vous en utilisant votre modem en tapant: wvdial

Vous devez avoir quelque chose du genre :

root@home:~# wvdial
–> WvDial: Internet dialer version 1.60
–> Cannot get information for serial port.
–> Initializing modem.
–> Sending: ATZ
ATZ
OK
–> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
–> Modem initialized.
–> Sending: ATDT*99#
–> Waiting for carrier.
ATDT*99#
CONNECT
–> Carrier detected. Starting PPP immediately.
–> Starting pppd at Mon Jun 22 14:01:21 2009
–> Pid of pppd: 6150
–> Using interface ppp0
–> pppd: ���[08][10]��[08]
–> pppd: ���[08][10]��[08]
–> pppd: ���[08][10]��[08]
–> pppd: ���[08][10]��[08]
–> pppd: ���[08][10]��[08]
–> pppd: ���[08][10]��[08]
–> local IP address x.x.x.x
–> pppd: ���[08][10]��[08]
–> remote IP address y.y.y.y
–> pppd: ���[08][10]��[08]
–> primary DNS address a.a.a.a
–> pppd: ���[08][10]��[08]
–> secondary DNS address b.b.b.b
–> pppd: ���[08][10]��[08]

N.B: laissez la fenêtre ouverte sinon le modem se déconnectera ! (Vous pouvez la deplacer dans un autre bureau par exemple.)

Si vous rencontrez des problèmes, envoyez moi un mail ou laissez un commentaire, et j’essayerai de vous aider!

28 responses to “Modem Huawei E156 g Méditel sous BackTrack / Ubuntu

  1. yassin moussoui 8 May 2010 at 7:10 pm

    hucker conixion modem meditel

  2. nourdine 10 June 2010 at 6:39 am

    bonjour,

    Ces derniers jours j’ai un probléme dans ma connexion meditel je me déconnécte chaque 5 minutes , j’ai un modem Huawei debit 3.6 M . Je sais pas d*si c’est du à un probléme dans mon modem ou le probléme provient de chez meditel

    • elvisscorpion 10 June 2010 at 9:42 pm

      Bonjour, j’ai un problème aussi sur H E156 G abonnement 3.6 Mb, que je n’ai jamais atteint d’ailleurs, mais il faut dire qu(en général le débit est correcte voir très correcte, jusqu’au Vendredi dernier. j’ai eesayé avec un autre pc chez moi, c’est le même problème. j’ai les dernière mise à jour sur mon modem, le signal hsdpa est au maximum, mais le débit est variable entre 0 et 1mb dans des plages de quelques secondes. disons que la connexion est extrêmement instable. j’ai d’ailleurs souffert pour arriver à afficher cette page (plusieurs rafraichissements sur le navigateur (F5)). Le test du ping sur le site recommandé par méditel, me sort un résultat E (Poor), j’ai contacté le support technique, ils m’ont dit qu’il n’y avait pas de problème à leur niveau. j’habite à casablanca dans la région de mers sultan. quelqu’un a t’il le même problème?

      • kzik 11 June 2010 at 11:41 am

        Mme problme signal chez moi, le dbit est instable et trs trs faible,j’ai 2 modems, un de maroc telecom et un autre meditel (3,6Mbps) et le dbit le dpasse pas 30-35kbps! mme histoire et mme discours des services techniques: aucun probleme n’est identit sur nos serveurs, essayer avec une autre machine, faites la MAJ du modem patati patata…! j’ai beau essay toutes les solutions possibles,connexion par vpn,changement de DNS mais le problme persiste encore,et le problme c’est qu’on encourage d’autres personne acheter des modems 3G sans rgler les problmes de navigation! Finalement, j’ai rutilis mon ancien modem Adsl qui fonctionne bien(plus o moins!)

  3. Yudi Bagus 23 June 2010 at 9:44 am

    Just want to say what a great blog you got here!
    I’ve been around for quite a lot of time, but finally decided to show my appreciation of your work!

    Thumbs up, and keep it going!

    • kzik 24 June 2010 at 2:13 pm

      I’m glad to know that you like the blog,and i’m sure you’re going to like it more after the work that’s gonna be made soon and the different subject posted!

  4. abdellah 4 July 2010 at 10:16 pm

    aussi Ces derniers jours j’ai un probléme dans ma connexion meditel je me déconnécte chaque 5 minutes ou moins , j’ai un modem Huawei debit 3.6 M .c’est la premier fois que je roncontre ce genre de problem avc mon modem noté bien que j’ai activé le connexion de trois mois !! aider Moi SVP

    • kzik 7 July 2010 at 4:49 pm

      Bonjour,Pense changer l’adresse DNS, tu peux opter pour OPENDNS, mais quand mme a reste provisoire et pas toujours fiable.

  5. omar 13 July 2010 at 2:02 am

    moi aussi j’ai le meme probleme avec le modem huawei meditel 3,6 ça fait plus de 20 jours que ce probleme perssiste , ma connexion ne dépasse pas 30k sachant qu’avant ce modem marchait à merveille .j’habite pres de benjdia a proximité de La Gironde si quelqu’un a une solution urgente

  6. AHMeD 17 July 2010 at 12:09 am

    moi aussi j’ai le meme probleme avec le modem huawei de meditel 3,6 Mbit/s ,ça fait maintenant plus de deux semaines que la connexion est instable pendant 3 jusqu’à 5 minutes et ensuite le débit devient nul !!! je souffre de ce problème seulement lorsque je me déplace dans des endroits les plus denses (comme sala al jadida :)) et ceci m^me si la couverture réseau est très bonne :c’est un problème de surcharge du réseau tt simplement
    la Solution c’est de réclamer le problème auprès de son opérateur , attendre ,attendre et attendre … sinon changer de ville :d

    • kzik 17 July 2010 at 11:20 am

      Bonjour,je ne pense pas que le fait de changer de ville pourra rsoudre le probleme(:D), mais plutot dposer le max de plainte et faire entendre sa voix comme c’etait le cas lors de la journe nationale sans portable.je prcise encore une fois que le probleme est un probleme d’emplacement et non autre chose, y’a des coins ou tu as le dbit au max meme si l’emplacement est satur d’utilisateurs, par ex au technopark, j’ai constat que le dbit etait tres tres bien et le telechargement nickel, mais chez moi c’etait la catastrophe!

  7. Wolfheart 21 July 2010 at 10:47 am

    Bonjour,tout d’abord je te remercie pour ce tutorial ainsi que le grand effort que tu fournis,
    voilà j’ai suivi le tuto à la lettre et tout se passe comme décrit dessus,mais je ne sais quoi faire après,je clique sur le modem pour l’installer ça me donne rien.sinon des messages comme quoi il n’est pas reconnu ou impossible de l’installer

    • kzik 22 July 2010 at 1:27 pm

      Bonjour, je te remercie pour l’interet que tu portes au blog!Bon, une fois tu as terminer l’installation, tu peux te connecter en sdmarrant un shell (invite de commande) ou tu dois taper ” wvdial ” (sans les “) et apres t’aura une srie de ligne qui vont s’afficher et qui vont stopper aprs cette ligne:” > pppd: …” tu peux meme verifier le voyant de ton modem , tu trouveras qu’il est bleu. ca ne sert a rien de cliquer sur le modem car les fichiers d’installation qu’il contient ne sont avalables que pour windows & Mac Os. N’hesite pas a me contacter si ca ne marche pas! Cordialement,

  8. alaoui azizi 29 July 2010 at 10:42 pm

    salam alikoum wa rahmatou allah wa barakatouh
    mabrouk alik ramadan in cha allah
    tien. j’ai unh prebleme avec le huwai E 156 avec ubuntu 10.04 . je n’arrives pas a me connecter
    avant avec ubuntu 9.10 et sabily je me connecte avec pppgneme etc
    peux tu me dire pratiquement et exactement comment faire ? je veux un copier coller car je ne suis assez doue en line de commande mais je peux suivre les directives pratiques et pas de theories et merci 10000000000fois
    a tire indicatif je suis age de 60 ans et imame khatib joumouaa . je ne suis pas trop jeune et merci mon fils qu edieu le tout puissant te preserve amine

    • kzik 1 August 2010 at 5:17 pm

      Wa alaikoum a ssalam wa rahmato lah taala wa barakatouh, le guide que j’ai cris s’applique mme a UBUNTU 10.10, sauf qu’il ya une difference entre les commandes. Sous ubuntu vous allez utiliser les meme commandes prcd par sudo (Pour avoir les droits administarateurs), et en arrivant a la 3eme tape vous devez remplacer “kate /etc/wvdial.conf ” par “gedit /etc/wvdial.conf “, car l’diteur de texte kate n’existe pas sous ubuntu(mais je ne suis pas sur de l’info). le reste est le mme sous ubuntu. j’essayerai de faire un autre tutoriel avec pppgnome trs prochainement. Cordialement,

  9. youssef 1 October 2010 at 10:15 pm

    slt tous le monde!
    c’est trois jour j’ai le même problème de connexion avec le modem E156G de meditel,je regardai les streaming en direct avec ,je suis toujours dans la même endroit,donc j’ai cru que c’est meditel qui a limité ma bande passante à 125kbits et je sais pas si c’est vrai ou non.

  10. said 6 October 2010 at 10:32 am

    salam aalikom j ai besion le méthode comment afficher le numéro de modém huawei E156G

  11. said 6 October 2010 at 10:35 am

    salam aalikom j ai besion le méthode comment afficher le numéro de modém huawei E156G

  12. anass 19 October 2010 at 3:45 pm

    sil vous pler “wa zinou f dibi ra finma kancharji kanb9a ntchamech dovant le pc”

  13. mohsin 30 October 2010 at 4:59 pm

    salut monde!
    j’ai un modem wuawei E220 maroc telecom,je vous demande l’aide car je sais pas comment le configurer sous Ubuntu 10.10 !! aidez moi svp je suis blocke’ !!
    MERCI !!

  14. bahae 31 October 2010 at 3:52 pm

    bonjour
    voilà j’ai un modem huawei e156g, j’ai essayer de l’installer sur ubuntu comme vous l’avez montrer mais lors ce que je tape vwdialconf il me donne le message : le programme wvdialconf n’est pas installé alors je i tape apt-get install wvdial il me donne trop de bla bla en fin une phrase qui dit impossible de récupérer http://ma.archive.ubuntu.com/ubuntu/pool/main/w/wvstream…. peut etre devrez vous lancer apt-get update ou essayer avec – – fix-missing?
    que doit je faire ?

  15. zirinky 9 December 2010 at 7:39 pm

    Bonjour,
    Je vous remercie pour l’effort que vous contribuer dans ce tutoriel (je m’inspire aussi pour pouvoir contribuer moi aussi dans le futur). J’ai suivi les étapes pour installer le modem sur Backtrack 4 r1, mais quand je tape wvdial, à certaine moment l’écran affiche “ERROR Invalid dial command”, si vous avez une idée, merci de bien vouloir la proposer.

  16. eyup 26 November 2011 at 12:18 pm

    bonjour, je viens de profiter de l’offre injaz 2011, et j’ai opté pour un modem meditel (huawei E173), la connexion et tres bonne sauf en cas de telechargement ou streaming. au debut du telechargement le debit est bon mais au bout de 5 min le telechargement s’arrête, et ca n’empéche que le modem n’est pas deconnecté et on peut continuer a naviger. je voudrai savoir si cela est un probleme de configuration du modem oubien c’est l’operateur qui bloc les telechargement

  17. xFaster 9 August 2013 at 9:31 pm

    Cela a marché trés bien…MERCI BIEN

    juste un truc.. c’est qu’il faut avoir de l’internet (pour qq instants) afin qu’on puisse installer wvdial.

    Cordialement.

  18. Erna 11 May 2015 at 3:16 pm

    Greetings! I just want to give you a large thumbs up
    for your fantastic information you’ve got listed here inside this post.
    I’m going to be certain to bookmark your site.

  19. Stainless Cookware Review 25 June 2015 at 12:02 pm

    Thanks for finally talking about >Modem Huawei E156 g Méditel sous BackTrack
    / Ubuntu | The Moroccan Geek <Loved it!

  20. neuracel review 12 July 2015 at 5:26 am

    A motivating discussion is definitely worth comment.
    I do believe that you need to write more about this subject,
    it may not be a taboo matter but usually folks don’t talk about
    such issues. To the next! Best wishes!!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: